$re = '/(?<=[a-z])-(?=[a-z])/';
$str = '-fjdkls six-nation-golden-cup-award - jfkdl-
a-b-c-4-_';
$subst = "\\-/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;