const regex = /(?<=[a-z])-(?=[a-z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[a-z])-(?=[a-z])', 'g')
const str = `-fjdkls six-nation-golden-cup-award - jfkdl-
a-b-c-4-_`;
const subst = `\\-/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);