import Foundation
let pattern = #"(?<=[a-z])-(?=[a-z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
-fjdkls six-nation-golden-cup-award - jfkdl-
a-b-c-4-_
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\-/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)