use strict;
my $str = '-fjdkls six-nation-golden-cup-award - jfkdl-
a-b-c-4-_';
my $regex = qr/(?<=[a-z])-(?=[a-z])/p;
my $subst = '\\\\-/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";