import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[a-z])-(?=[a-z])";
final String string = "-fjdkls six-nation-golden-cup-award - jfkdl-\n"
+ "a-b-c-4-_";
final String subst = "\\\\-/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}