#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\/[^.\n]*?(?:=.*)?$"
Local $sString = "/test" & @CRLF & _
"/test/123" & @CRLF & _
"/test/123/1" & @CRLF & _
"/test/123/1?q=test" & @CRLF & _
"/test/123/1?q=test.period" & @CRLF & _
"/test.js" & @CRLF & _
"/img/123.jpg" & @CRLF & _
"/script/app.js?version=1.0" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)