import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/[^.\\n]*?(?:=.*)?$";
final String string = "/test\n"
+ "/test/123\n"
+ "/test/123/1\n"
+ "/test/123/1?q=test\n"
+ "/test/123/1?q=test.period\n"
+ "/test.js\n"
+ "/img/123.jpg\n"
+ "/script/app.js?version=1.0\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}