package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/[^.\n]*?(?:=.*)?$`)
var str = `/test
/test/123
/test/123/1
/test/123/1?q=test
/test/123/1?q=test.period
/test.js
/img/123.jpg
/script/app.js?version=1.0
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}