const regex = /\/[^.\n]*?(?:=.*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/[^.\\n]*?(?:=.*)?$', 'gm')
const str = `/test
/test/123
/test/123/1
/test/123/1?q=test
/test/123/1?q=test.period
/test.js
/img/123.jpg
/script/app.js?version=1.0
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);