re = /\/[^.\n]*?(?:=.*)?$/m
str = '/test
/test/123
/test/123/1
/test/123/1?q=test
/test/123/1?q=test.period
/test.js
/img/123.jpg
/script/app.js?version=1.0
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result