import Foundation
let pattern = #"\/[^.\n]*?(?:=.*)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/test
/test/123
/test/123/1
/test/123/1?q=test
/test/123/1?q=test.period
/test.js
/img/123.jpg
/script/app.js?version=1.0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)