use strict;
my $str = '/test
/test/123
/test/123/1
/test/123/1?q=test
/test/123/1?q=test.period
/test.js
/img/123.jpg
/script/app.js?version=1.0
';
my $regex = qr/\/[^.\n]*?(?:=.*)?$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";