# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=<\\/a>)(\w+)/ $1/gm;t' <<< "<a href=\"blah.com\">Hello</a>World // Here we need to put space between Hello and World
<a href=\"blah.com\">Hello</a> World // Do not touch this
<a href=\"blah.com\">Hello</a><b>World</b> // do not touch this"