import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<\\/a>)(\\w+)";
final String string = "<a href=\"blah.com\">Hello</a>World // Here we need to put space between Hello and World\n\n"
+ "<a href=\"blah.com\">Hello</a> World // Do not touch this\n\n"
+ "<a href=\"blah.com\">Hello</a><b>World</b> // do not touch this";
final String subst = " $1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}