re = /(?<=<\/a>)(\w+)/m
str = '<a href="blah.com">Hello</a>World // Here we need to put space between Hello and World
<a href="blah.com">Hello</a> World // Do not touch this
<a href="blah.com">Hello</a><b>World</b> // do not touch this'
subst = ' $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result