#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=<\/a>)(\w+)"
Local $sString = "<a href="blah.com">Hello</a>World // Here we need to put space between Hello and World" & @CRLF & _
"" & @CRLF & _
"<a href="blah.com">Hello</a> World // Do not touch this" & @CRLF & _
"" & @CRLF & _
"<a href="blah.com">Hello</a><b>World</b> // do not touch this"
Local $sSubst = " $1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)