use strict;
my $str = '<a href="blah.com">Hello</a>World // Here we need to put space between Hello and World
<a href="blah.com">Hello</a> World // Do not touch this
<a href="blah.com">Hello</a><b>World</b> // do not touch this';
my $regex = qr/(?<=<\/a>)(\w+)/mp;
my $subst = ' $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";