import Foundation
let pattern = #"(?<=<\/a>)(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<a href="blah.com">Hello</a>World // Here we need to put space between Hello and World
<a href="blah.com">Hello</a> World // Do not touch this
<a href="blah.com">Hello</a><b>World</b> // do not touch this
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)