using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<\/a>)(\w+)";
string substitution = @" $1";
string input = @"<a href=""blah.com"">Hello</a>World // Here we need to put space between Hello and World
<a href=""blah.com"">Hello</a> World // Do not touch this
<a href=""blah.com"">Hello</a><b>World</b> // do not touch this";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}