#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?:\/\/)?(?:www\.)?(?:\w+?\.){2}(?:com|us)$"
Local $sString = "subdomain.domain.aaa123" & @CRLF & _
"subdomain.domain" & @CRLF & _
"subdomain.domain.com" & @CRLF & _
"subdomain.domain.us" & @CRLF & _
"https://subdomain.domain.us" & @CRLF & _
"http://subdomain.domain.com" & @CRLF & _
"www.subdomain.domain.us" & @CRLF & _
"http://www.subdomain.domain.us"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")