using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https?:\/\/)?(?:www\.)?(?:\w+?\.){2}(?:com|us)$";
string input = @"subdomain.domain.aaa123
subdomain.domain
subdomain.domain.com
subdomain.domain.us
https://subdomain.domain.us
http://subdomain.domain.com
www.subdomain.domain.us
http://www.subdomain.domain.us";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}