import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)?(?:www\\.)?(?:\\w+?\\.){2}(?:com|us)$";
final String string = "subdomain.domain.aaa123\n"
+ "subdomain.domain\n"
+ "subdomain.domain.com\n"
+ "subdomain.domain.us\n"
+ "https://subdomain.domain.us\n"
+ "http://subdomain.domain.com\n"
+ "www.subdomain.domain.us\n"
+ "http://www.subdomain.domain.us";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}