package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:https?:\/\/)?(?:www\.)?(?:\w+?\.){2}(?:com|us)$`)
var str = `subdomain.domain.aaa123
subdomain.domain
subdomain.domain.com
subdomain.domain.us
https://subdomain.domain.us
http://subdomain.domain.com
www.subdomain.domain.us
http://www.subdomain.domain.us`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}