re = /^(?:https?:\/\/)?(?:www\.)?(?:\w+?\.){2}(?:com|us)$/m
str = 'subdomain.domain.aaa123
subdomain.domain
subdomain.domain.com
subdomain.domain.us
https://subdomain.domain.us
http://subdomain.domain.com
www.subdomain.domain.us
http://www.subdomain.domain.us'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end