const regex = /^(?:https?:\/\/)?(?:www\.)?(?:\w+?\.){2}(?:com|us)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https?:\\\/\\\/)?(?:www\\.)?(?:\\w+?\\.){2}(?:com|us)$', 'gm')
const str = `subdomain.domain.aaa123
subdomain.domain
subdomain.domain.com
subdomain.domain.us
https://subdomain.domain.us
http://subdomain.domain.com
www.subdomain.domain.us
http://www.subdomain.domain.us`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}