import Foundation
let pattern = #"^(?:https?:\/\/)?(?:www\.)?(?:\w+?\.){2}(?:com|us)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
subdomain.domain.aaa123
subdomain.domain
subdomain.domain.com
subdomain.domain.us
https://subdomain.domain.us
http://subdomain.domain.com
www.subdomain.domain.us
http://www.subdomain.domain.us
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)