// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:https?:\/\/)?(?:www\.)?(?:\w+?\.){2}(?:com|us)$").unwrap();
let string = "subdomain.domain.aaa123
subdomain.domain
subdomain.domain.com
subdomain.domain.us
https://subdomain.domain.us
http://subdomain.domain.com
www.subdomain.domain.us
http://www.subdomain.domain.us";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}