using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(red|blue|green) (colou?r|chroma)";
string substitution = @"\1 hue";
string input = @"red color";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}