$re = '/(red|blue|green) (colou?r|chroma)/m';
$str = 'red color';
$subst = "\1 hue";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;