const regex = /(red|blue|green) (colou?r|chroma)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(red|blue|green) (colou?r|chroma)', 'gm')
const str = `red color`;
const subst = `\1 hue`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);