package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(red|blue|green) (colou?r|chroma)`)
var str = `red color`
var substitution = "\1 hue"
fmt.Println(re.ReplaceAllString(str, substitution))
}