using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(the|an?)\b\s+";
string substitution = @"";
string input = @"The test file.txt
These test files.txt
A test file.txt
Another test file.txt
An older test file.txt
At the disco.txt";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}