// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^(the|an?)\b\s+").unwrap();
let string = "The test file.txt
These test files.txt
A test file.txt
Another test file.txt
An older test file.txt
At the disco.txt";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}