const regex = /^(the|an?)\b\s+/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(the|an?)\\b\\s+', 'igm')
const str = `The test file.txt
These test files.txt
A test file.txt
Another test file.txt
An older test file.txt
At the disco.txt`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);