# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(the|an?)\b\s+"
test_str = ("The test file.txt\n"
"These test files.txt\n"
"A test file.txt\n"
"Another test file.txt\n"
"An older test file.txt\n"
"At the disco.txt")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.