re = /^(the|an?)\b\s+/im
str = 'The test file.txt
These test files.txt
A test file.txt
Another test file.txt
An older test file.txt
At the disco.txt'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result