$re = '/^(the|an?)\b\s+/im';
$str = 'The test file.txt
These test files.txt
A test file.txt
Another test file.txt
An older test file.txt
At the disco.txt';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;