use strict;
my $str = 'The test file.txt
These test files.txt
A test file.txt
Another test file.txt
An older test file.txt
At the disco.txt';
my $regex = qr/^(the|an?)\b\s+/imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";