import Foundation
let pattern = #"^(the|an?)\b\s+"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
The test file.txt
These test files.txt
A test file.txt
Another test file.txt
An older test file.txt
At the disco.txt
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)