using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[AM]\d{4}.*|(.+)";
string input = @"A1234
M3232
M3425435324
MM3453
JHLKJGA1234
string with nothing";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}