const regex = /[AM]\d{4}.*|(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[AM]\\d{4}.*|(.+)', 'gm')
const str = `A1234
M3232
M3425435324
MM3453
JHLKJGA1234
string with nothing`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}