$re = '/[AM]\d{4}.*|(.+)/m';
$str = 'A1234
M3232
M3425435324
MM3453
JHLKJGA1234
string with nothing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);