// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[AM]\d{4}.*|(.+)").unwrap();
let string = "A1234
M3232
M3425435324
MM3453
JHLKJGA1234
string with nothing";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}