package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[AM]\d{4}.*|(.+)`)
var str = `A1234
M3232
M3425435324
MM3453
JHLKJGA1234
string with nothing`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}