import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[AM]\\d{4}.*|(.+)";
final String string = "A1234\n"
+ "M3232\n"
+ "M3425435324\n"
+ "MM3453\n"
+ "JHLKJGA1234\n"
+ "string with nothing";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}