re = /[AM]\d{4}.*|(.+)/m
str = 'A1234
M3232
M3425435324
MM3453
JHLKJGA1234
string with nothing'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end