using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\s\S]*smsKod: (\d{8})[\s\S]*";
string input = @"smsKod: 24992129 dla
operacji: zmiana limitów
transakcyjnych 27.03.2015
11.17";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}