import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\s\\S]*smsKod: (\\d{8})[\\s\\S]*";
final String string = "smsKod: 24992129 dla \n"
+ "operacji: zmiana limitów \n"
+ "transakcyjnych 27.03.2015\n"
+ "11.17";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}