const regex = /[\s\S]*smsKod: (\d{8})[\s\S]*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\s\\S]*smsKod: (\\d{8})[\\s\\S]*', '')
const str = `smsKod: 24992129 dla
operacji: zmiana limitów
transakcyjnych 27.03.2015
11.17`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}