$re = '/[\s\S]*smsKod: (\d{8})[\s\S]*/';
$str = 'smsKod: 24992129 dla
operacji: zmiana limitów
transakcyjnych 27.03.2015
11.17';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);